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PART I: THEORETICAL FOUNDATION OF HYDROLOGICAL 
ANALYSIS 

1. Introduction to Hydrological Modelling and Watershed Analysis 

Hydrological analysis using Geographic Information Systems (GIS) provides the quantitative basis for 

water resource management, flood forecasting, soil erosion modelling, and environmental impact 

assessment. The drainage basin (or catchment) is the principal unit of hydrological investigation: it 

represents the area of land surface that contributes surface runoff to a single outlet through a connected 

channel network. Delineation of this contributing area, identification of the stream network, and 

characterisation of basin morphometry together form the foundation of distributed and semi-distributed 

hydrological models. 

The Spatial Analyst Hydrology toolset in ArcGIS Pro implements a sequence of raster-based operations 

that transform a Digital Elevation Model (DEM) into hydrologically meaningful surfaces. The toolset 

performs sink filling, flow-direction encoding, flow-accumulation computation, stream-network extraction, 

stream ordering, and watershed delineation. Each operation produces a spatial dataset that may be used 

independently or combined with subsequent operations within an ordered analytical chain. 

These tools are widely applied in academic research and operational hydrology. The outputs are used 

as inputs to physically-based models such as the Soil and Water Assessment Tool (SWAT), the 

Hydrologic Engineering Center's Hydrologic Modeling System (HEC-HMS), and the MIKE SHE 

distributed hydrological framework. In Indian conditions, the toolset has been employed for groundwater 

recharge assessment in lateritic terrains, flood hazard mapping in deltaic and coastal river basins, and 

morphometric prioritisation of micro-watersheds for soil and water conservation planning. 

2. Historical Context and Significance of Digital Terrain Analysis 

The origin of automated drainage extraction from digital elevation data is attributed to the work of 

O’Callaghan and Mark (1984), who proposed the deterministic eight-direction (D8) algorithm for assigning 

flow direction in a regular grid. This algorithm, despite its simplicity and the discretisation error it 

introduces, remains the most widely used flow-direction method in operational hydrological GIS. 

Subsequent refinements introduced multiple-flow-direction methods (Quinn et al., 1991), the D-Infinity 

method based on triangular facet decomposition (Tarboton, 1997), and stream-burning techniques to 

enforce known channel locations. 

The integration of these algorithms into commercial GIS software began with ArcInfo Workstation in the 

late 1980s, where the GRID module exposed hydrological functions through Arc Macro Language (AML) 

scripts. Jenson and Domingue (1988) formalised the modern raster-hydrology workflow: fill sinks, 

compute flow direction, compute flow accumulation, threshold the accumulation grid to extract streams, 

and delineate watersheds from pour points. This sequence remains the canonical workflow in ArcGIS 

Pro and is preserved across QGIS (using GRASS or SAGA), GRASS GIS native r.watershed, and the 

open-source TauDEM library. 
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ArcGIS Pro inherits and extends this lineage. The Spatial Analyst Hydrology toolset is licensed as part of 

the Spatial Analyst extension and is required for advanced raster hydrology. ArcGIS Pro additionally 

provides newer tools such as Derive Stream As Line and Derive Stream As Raster, which combine 

multiple steps of the classical workflow into single operations and apply to wide application in rapid, 

exploratory analysis. 

3. The ArcGIS Pro Hydrology Toolset 

The Hydrology toolset is contained within the Spatial Analyst toolbox in ArcGIS Pro. It groups together 

the raster operations required to model surface water flow over a terrain. The toolset assumes that gravity 

is the only force driving overland flow and that flow follows the steepest descent path from each cell. 

These assumptions are appropriate for first-order hydrological characterisation but should be revisited 

when modelling karst, urban drainage, or terrain with strong subsurface flow contributions. 

3.1 Evolution from ArcInfo Workstation to ArcGIS Pro 

Version Year Platform Key Features 

ArcInfo GRID Late 1980s ArcInfo Workstation (UNIX) First implementation of Jenson–
Domingue workflow through GRID and 
AML 

ArcView 3.x Mid 1990s ArcView with Spatial 
Analyst extension 

Hydrologic Modeling sample extension; 
menu-driven access to fill, 
flowdirection, flowaccumulation 

ArcGIS 9.x 2004–2010 ArcMap with Spatial 
Analyst 

Hydrology toolset formalised; 
Watershed and Basin tools 
standardised 

ArcGIS 10.x 2010–2022 ArcMap and ArcCatalog D-Infinity option added for Flow 
Direction (10.4+); Geometric Network 
deprecated in favour of raster–feature 
workflows 

ArcGIS Pro 
2.x 

2018–2022 ArcGIS Pro 64-bit MFD option added; Storage Capacity 
tool introduced; Python 3 (arcpy) 
replaces Python 2 

ArcGIS Pro 
3.x 

2022–
present 

ArcGIS Pro 3.0–3.x Derive Stream As Line and Derive 
Stream As Raster tools; performance 
improvements through parallel 
processing 

3.2 Tools in the Spatial Analyst Hydrology Toolset 

The toolset exposes the following tools in ArcGIS Pro 3.x. Each tool is documented with its required 

inputs, output type, and the typical position it occupies within the workflow. 

Tool Output Type Workflow 
Position 

Primary Use 

Fill Raster (DEM) Step 1 Removes spurious sinks from the 
input DEM 
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Tool Output Type Workflow 
Position 

Primary Use 

Flow Direction Raster (integer 
codes) 

Step 2 Encodes the direction of steepest 
descent for each cell 

Flow Accumulation Raster (counts) Step 3 Counts upstream cells contributing to 
each cell 

Flow Length Raster (distance) Optional Computes upstream or downstream 
flow distance 

Sink Raster Diagnostic Identifies cells of internal drainage in 
unfilled DEM 

Con (with 
threshold) 

Raster 
(1/NoData) 

Step 4 Defines stream cells from the 
accumulation raster 

Stream Link Raster (integer 
IDs) 

Step 5 Assigns unique IDs to stream 
segments between junctions 

Stream Order Raster (order 
values) 

Step 6 Assigns Strahler or Shreve order to 
stream segments 

Stream to Feature Polyline feature 
class 

Step 7 Vectorises the stream raster 

Snap Pour Point Raster (point 
cells) 

Step 8 Relocates user-supplied outlets onto 
high-accumulation cells 

Watershed Raster Step 9 Delineates contributing area for 
snapped pour points 

Basin Raster Step 10 Delineates all natural drainage 
basins from the flow-direction raster 

Storage Capacity Table Optional Computes elevation–volume 
relationship for reservoirs 

Derive Stream As 
Line 

Polyline feature 
class 

All-in-one Combines fill, flow direction, 
accumulation, and vectorisation 

Derive Stream As 
Raster 

Raster All-in-one Same as above with raster output 

4. Fundamental Concepts and Terminology 

4.1 Digital Elevation Model (DEM) 

A Digital Elevation Model is a raster representation of the bare-earth elevation surface, in which each cell 

stores a single elevation value (typically in metres above mean sea level). The horizontal resolution of 

the DEM determines the smallest hydrological feature that can be resolved; the vertical accuracy governs 

the reliability of derived flow paths. A 30 m SRTM DEM resolves first-order channels of approximately 

60–90 m width, while a 1 m LiDAR DEM resolves rills, terraces, and minor channel structures. Selection 

of DEM resolution should match the scale of the hydrological question rather than the highest available 

resolution. 
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4.2 Drainage Basin and Watershed 

A drainage basin is the area of land surface that drains to a common outlet through a connected stream 

network. The terms catchment, watershed, and drainage basin are used interchangeably in international 

literature; in Indian usage following the Central Water Commission, basin denotes the largest unit (e.g., 

the Krishna basin), sub-basin or watershed denotes an intermediate unit, and micro-watershed denotes 

a unit of approximately 500 to 2000 hectares used in soil and water conservation planning. The boundary 

of a basin is the drainage divide, which separates surface flow into two adjacent basins. 

4.3 Pour Point and Outlet 

A pour point (also called outlet or basin outlet) is the cell at which surface flow exits a drainage basin. In 

the Watershed tool, pour points are user-supplied as a point feature class or as a raster of designated 

cells. The accuracy of the resulting watershed depends critically on the precise placement of the pour 

point. A pour point placed even one cell off the main channel may produce a degenerate watershed of 

only a few cells. The Snap Pour Point tool addresses this issue by relocating the supplied point onto the 

highest-accumulation cell within a user-defined search radius. 

4.4 Sinks and Spurious Pits 

A sink is a cell whose elevation is lower than all of its eight neighbours, such that no surface flow direction 

can be assigned by the D8 method. Sinks may be genuine endorheic features (e.g., closed depressions 

in arid regions) or spurious artefacts arising from DEM interpolation, sensor noise, or vertical quantisation. 

Genuine sinks are rare in humid Indian conditions, and the standard practice is to fill all sinks before 

computing flow direction. The Sink tool reports the locations of sinks in an unfilled DEM and is 

recommended as a diagnostic step before the Fill operation. 

4.5 Stream Network and Drainage Density 

The stream network is the set of cells that exceed a flow-accumulation threshold and are therefore 

considered to carry channelised flow. The threshold (often denoted A_c or critical support area) is the 

smallest contributing area required to maintain a perennial or persistent channel. In Indian humid regions, 

A_c values of 0.5–1.0 km² are commonly used; in semi-arid regions, A_c values of 2–10 km² are 

appropriate. Drainage density (D_d) is defined as the total length of streams divided by the basin area 

and is expressed in km/km². D_d is sensitive to the chosen threshold and should always be reported 

alongside the threshold value. 

5. Algorithms in the Hydrology Toolset 

5.1 D8 Flow Direction Algorithm 

The deterministic eight-direction (D8) algorithm assigns flow from each cell to one of its eight neighbours 

in the direction of steepest descent. The slope to each neighbour is calculated as the elevation difference 

divided by the inter-cell distance: 1 cell-width for the four cardinal neighbours and √2 cell-widths for the 

four diagonal neighbours. The neighbour with the maximum slope receives all the flow. ArcGIS Pro 
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encodes the eight directions as powers of two: East = 1, Southeast = 2, South = 4, Southwest = 8, West 

= 16, Northwest = 32, North = 64, and Northeast = 128. The D8 algorithm is computationally efficient and 

exactly preserves drainage area, but introduces parallel-flow artefacts on planar surfaces and does not 

represent flow divergence. 

Slope formula at cell c to neighbour n: 

    Slope(c, n) = (Z_c − Z_n) / d(c, n) 

where Z is elevation and d(c, n) is 1 for cardinal neighbours and √2 for diagonal neighbours. 

5.2 D-Infinity Flow Direction Algorithm 

The D-Infinity (D∞) algorithm proposed by Tarboton (1997) addresses the planar-flow limitation of D8. 

Each 3×3 cell neighbourhood is partitioned into eight triangular facets, and the steepest downslope 

direction is computed as a continuous angle in the range [0, 2π). Flow is then partitioned between the 

two D8 neighbours that bracket this angle, with weights proportional to the angular proximity of the flow 

direction to each neighbour. This produces smoother accumulation surfaces and reduces the parallel-

flow artefacts of D8, at the cost of slightly higher computational expense and a more complex flow-

direction encoding (a floating-point angle rather than an integer code). 

5.3 Multiple Flow Direction (MFD) 

The Multiple Flow Direction algorithm (Quinn et al., 1991) distributes flow from each cell to all downslope 

neighbours, with the partition weights proportional to the slope to each neighbour raised to a power p 

(commonly p = 1.1 in ArcGIS Pro). MFD is appropriate for representing divergent flow on hillslopes and 

ridge tops, and is widely used for soil erosion modelling and topographic wetness index (TWI) 

calculations. It is less appropriate for delineating discrete channel networks, where convergent flow is the 

dominant signal. 

5.4 Strahler and Shreve Stream Ordering 

Stream ordering schemes assign an integer rank to each segment of a channel network. Two schemes 

are implemented in the Stream Order tool. In the Strahler (1957) method, headwater (first-order) streams 

have order 1; when two streams of order n meet, the resulting downstream segment has order n+1; when 

two streams of different order meet, the downstream segment retains the higher of the two orders. In the 

Shreve (1966) method, headwater streams have magnitude 1; at every confluence the magnitudes of the 

joining streams are summed. Strahler order is more widely used for morphometric analysis and is the 

default in most Indian morphometric studies; Shreve magnitude is more sensitive to network density and 

is used in network-topology research. 

6. Data Sources for Hydrological Analysis 

DEM data form the principal input for all tools in the Hydrology toolset. The selection of the appropriate 

DEM should consider the spatial scale of the basin, the vertical accuracy required, the temporal currency 

of the surface (post-event versus pre-event), and the licensing terms applicable to academic and 

commercial use. 
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Source Coverage Spatial 
Resolution 

Vertical 
Accuracy 

Access 

SRTM 1 Arc-Second 
Global 

60° N to 56° 
S 

~30 m ± 16 m (LE90) USGS EarthExplorer 
(free) 

ASTER GDEM v3 83° N to 83° 
S 

~30 m ± 17 m (LE95) NASA Earthdata (free) 

ALOS PALSAR RTC Global ~12.5 m ± 10 m ASF Vertex (free, 
registration) 

CartoDEM v3 R1 India only 30 m ± 8 m (RMSE) ISRO Bhuvan 
(registration required) 

Copernicus DEM 
(GLO-30) 

Global 30 m ± 4 m (LE90) Copernicus Data Space 
(free) 

NASADEM 60° N to 56° 
S 

30 m ± 5–10 m NASA Earthdata (free) 

LiDAR (state DEM) Selected 
Indian states 

1–5 m ± 0.15–0.5 m State remote sensing 
centres / Survey of India 

UAV Photogrammetry Project-
specific 

0.05–0.5 m ± 0.05–0.20 m User-acquired 

For Indian river basins, Copernicus GLO-30 and CartoDEM v3 R1 are the recommended baseline 

products, with LiDAR or UAV-derived DEMs preferred where available for sub-basin and micro-

watershed studies. SRTM 1 Arc-Second remains useful for regional analysis owing to its long temporal 

stability and global homogeneity, although vertical artefacts in vegetated and steep terrain may require 

post-processing. 
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PART II: STEP-BY-STEP HYDROLOGY WORKFLOW IN 
ArcGIS PRO 

7. Data Acquisition and Preparation 

7.1 Obtaining DEM Data 

Step 7.1.1: Identify Data Source 

Select a DEM whose resolution is appropriate to the scale of the study basin. For river basins exceeding 

1000 km², Copernicus GLO-30 or SRTM 30 m are suitable. For sub-basins below 100 km² and for urban 

drainage studies, a 5–10 m DEM derived from CartoDEM, ALOS PALSAR, or LiDAR is preferable. 

Step 7.1.2: Download and Mosaic 

DEM tiles should be downloaded in the native projection (typically Geographic WGS 84 for global 

products) and mosaicked using the Mosaic to New Raster tool (Data Management Tools > Raster > 

Raster Dataset). Specify the cell size of the input tiles, the pixel type (32-bit floating point), and the number 

of bands as 1. 

Step 7.1.3: Reproject to UTM 

Reproject the mosaicked DEM to the appropriate UTM zone using the Project Raster tool (Data 

Management Tools > Projections and Transformations). For peninsular India, the relevant zones are 

UTM 43N (EPSG:32643) for longitudes 72°–78° E, UTM 44N (EPSG:32644) for 78°–84° E, and UTM 

45N (EPSG:32645) for 84°–90° E. Use the bilinear resampling method for elevation data. 

7.2 DEM Pre-processing 

Step 7.2.1: Clip to Study Area 

Clip the projected DEM to a rectangular extent that encloses the study basin with a buffer of 

approximately 10 percent on each side. The buffer prevents edge effects in flow-direction computation. 

Use the Extract by Mask tool with a polygon feature class as the mask. 

Step 7.2.2: Inspect and Document 

Examine the histogram of elevation values to identify outliers, no-data regions, and vertical artefacts. 

Document the DEM source, acquisition date, native resolution, projected resolution, vertical datum 

(typically EGM96 or EGM2008 for global products), and CRS in the methodology section of the project. 

8. Setting Up the GIS Environment 

Step 8.1: Geodatabase Configuration 

Create a file geodatabase (.gdb) within the project workspace using the Create File Geodatabase tool. 

All raster intermediate outputs and the final stream and watershed feature classes will be stored in this 

geodatabase. The recommended folder structure is: Project/Data (for input data), Project/Workspace (for 

the geodatabase and scratch outputs), and Project/Outputs (for final maps and reports). 
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Step 8.2: Environment Settings 

Open the Geoprocessing Environments dialogue (Analysis tab > Environments) and configure the 

following globally: 

• Workspace: Project/Workspace/hydrology.gdb 

• Scratch Workspace: Project/Workspace/scratch.gdb 

• Output Coordinate System: WGS 1984 UTM Zone 44N (EPSG:32644) or appropriate zone 

• Cell Size: same as input DEM (e.g., 30 m for SRTM) 

• Snap Raster: the input DEM (ensures all output rasters are co-registered) 

• Extent: same as DEM extent 

Step 8.3: Enable Spatial Analyst 

Verify that the Spatial Analyst extension is enabled in Project > Licensing. Without this extension, the 

Hydrology toolset is not available. 

9. Step 1: Fill Sinks 

Tool: Spatial Analyst Tools > Hydrology > Fill 

Purpose: The Fill tool removes spurious sinks from the input DEM by raising the elevation of each sink 

cell to the elevation of its lowest pour point. The output is a hydrologically conditioned DEM in which 

every cell drains to a basin outlet. 

Step 9.1: Open the Fill Tool 

Locate the Fill tool in the Geoprocessing pane (Analysis tab > Tools > Spatial Analyst Tools > Hydrology 

> Fill). Set the input as the projected, clipped DEM. Leave the Z limit parameter blank to fill all sinks; 

specify a Z limit (in vertical units of the DEM) only when a known maximum depression depth should be 

preserved. 

Step 9.2: Run and Verify 

Set the output filename as DEM_fill.tif (or in the geodatabase as DEM_fill). After execution, compute the 

cell-wise difference between the filled and unfilled DEM using the Raster Calculator: "DEM_fill" − 

"DEM_raw". The resulting raster should show small positive values (typically less than 1–2 m) at locations 

of filled sinks and zero elsewhere. Large filled regions may indicate data voids or systematic DEM errors 

and should be investigated before proceeding. 

Output: a hydrologically conditioned DEM in which all cells drain to the basin outlet. 

10. Step 2: Flow Direction 

Tool: Spatial Analyst Tools > Hydrology > Flow Direction 

Purpose: Encodes the direction of steepest descent from each cell to one of its eight neighbours (D8) or 

partitions flow among neighbours (D-Infinity, MFD). 

Step 10.1: Configure the Tool 
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Parameter Setting Notes 

Input surface raster DEM_fill Filled DEM from Step 1 

Output flow direction 
raster 

FlowDir_D8 Integer raster of flow codes 

Force all edge cells to 
flow outward 

Checked Prevents edge artefacts 

Output drop raster (optional) Records the drop in elevation along the flow path 

Flow direction type D8 Use MFD for divergent flow studies; D-Infinity for 
TWI 

Step 10.2: Interpretation of D8 Codes 

The output is an integer raster with the following values: 1 = East, 2 = Southeast, 4 = South, 8 = 

Southwest, 16 = West, 32 = Northwest, 64 = North, 128 = Northeast. Cells with no defined flow direction 

(typically the basin outlet at the DEM edge) receive a value of zero. 

Step 10.3: Validate 

Display the flow-direction raster with a unique-values symbology and overlay the DEM. The codes should 

follow the topographic gradient: cells on a south-facing slope should display values dominated by 4 

(South). Anomalies indicate residual sinks or DEM errors. 

11. Step 3: Flow Accumulation 

Tool: Spatial Analyst Tools > Hydrology > Flow Accumulation 

Purpose: Computes, for each cell, the number of upstream cells that drain into it. The flow-accumulation 

raster is the basis for stream-network extraction and for computing the topographic wetness index. 

Step 11.1: Configure 

Parameter Setting Notes 

Input flow direction 
raster 

FlowDir_D8 From Step 2 

Output accumulation 
raster 

FlowAcc Counts of upstream cells 

Input weight raster (optional) Use for weighted accumulation, e.g., rainfall-
weighted 

Output data type Float Use Integer only for unweighted small basins 

Flow direction type D8 Must match Step 2 

Step 11.2: Display 

The raw accumulation raster is dominated by zero-valued hillslope cells and a small number of high-

valued channel cells, producing a histogram with extreme right-skew. For visualisation, apply a log-

transform to the symbology: in Layer Properties > Symbology, set the stretch type to Standard Deviation 

with n = 2, or apply a logarithmic stretch. The channel network will appear as bright lines against a dark 

hillslope background. 
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Step 11.3: Convert Counts to Area 

To express accumulation as contributing area in m², multiply the accumulation raster by the cell area (cell 

size squared) using the Raster Calculator: "FlowAcc" * 900 for a 30 m DEM. To express in km², divide 

further by 1,000,000. 

12. Step 4: Stream Definition (Threshold) 

Tool: Spatial Analyst Tools > Map Algebra > Raster Calculator (with Con expression) 

Purpose: Extracts the stream-cell network by thresholding the flow-accumulation raster. Cells with 

accumulation greater than or equal to the critical support area are classified as streams; all other cells 

receive NoData. 

Step 12.1: Choose the Threshold 

The threshold (T) should match the smallest channel that the analyst wishes to represent, expressed in 

number of upstream cells. For a 30 m DEM: 

Climate / Terrain T (cells, 30 m) Equivalent Area (km²) Resulting Network 

Humid tropical (Western 
Ghats) 

500–1000 0.45–0.90 Dense; includes 1st-
order rivulets 

Sub-humid (Deccan 
Plateau) 

1000–2000 0.90–1.80 Moderate; perennial 1st-
order 

Semi-arid (Rayalaseema, 
Marathwada) 

5000–10000 4.50–9.00 Sparse; ephemeral 
channels excluded 

Arid (Thar) 10000–20000 9.00–18.00 Trunk channels only 

Step 12.2: Run the Conditional Statement 

In Raster Calculator, enter: 

    Con("FlowAcc" >= 1000, 1) 

This produces a raster in which stream cells have a value of 1 and all other cells are NoData. Save the 

output as Stream_raw. 

Step 12.3: Sensitivity Analysis 

Generate stream networks at three thresholds (e.g., T = 500, 1000, 2000) and overlay them on the 

topographic map and on Survey of India 1:50,000 sheets where available. Choose the threshold that best 

matches the mapped blue-line streams in the SOI sheet for the dominant terrain type. Document the 

chosen T in the methodology and report drainage density at this T. 

13. Step 5: Stream Link 

Tool: Spatial Analyst Tools > Hydrology > Stream Link 

Purpose: Assigns a unique integer identifier to each segment of the stream network between successive 

junctions or between a headwater and a junction. 
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Step 13.1: Configure 

• Input stream raster: Stream_raw (from Step 4) 

• Input flow direction raster: FlowDir_D8 (from Step 2) 

• Output: StreamLink 

Step 13.2: Verify 

Display the output with a unique-values symbology. Each stream segment should appear in a distinct 

colour. Segments terminate at every confluence and at the basin outlet. The total number of segments 

equals the number of unique values in the attribute table. 

14. Step 6: Stream Order 

Tool: Spatial Analyst Tools > Hydrology > Stream Order 

Purpose: Assigns a numeric order to each stream segment using either the Strahler or the Shreve 

scheme. 

Step 14.1: Configure 

• Input stream raster: Stream_raw 

• Input flow direction raster: FlowDir_D8 

• Method: STRAHLER (recommended for morphometric analysis) 

• Output: StreamOrder_S 

Step 14.2: Inspect Order Statistics 

Open the attribute table of the output raster and record the maximum order, the count of segments at 

each order, and the total length of streams at each order (the latter requires conversion to features in 

Step 7). For typical Indian sub-basins of 100–1000 km², expected maximum Strahler order ranges from 

4 to 6. 

15. Step 7: Stream to Feature 

Tool: Spatial Analyst Tools > Hydrology > Stream to Feature 

Purpose: Converts the stream raster to a polyline feature class with attributes preserving stream order 

and link identifier. 

Step 15.1: Configure 

• Input stream raster: StreamOrder_S 

• Input flow direction raster: FlowDir_D8 

• Simplify polylines: Checked (reduces vertex count without changing topology) 

• Output: StreamNetwork (polyline feature class) 

Step 15.2: Compute Geometry Attributes 
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Open the attribute table of the output and use Calculate Geometry to add a Length_m field in metres. 

Aggregate this field by stream order using Summary Statistics to report total stream length per order 

class. These values feed directly into morphometric analysis (bifurcation ratio, stream-length ratio, 

drainage density). 

16. Step 8: Snap Pour Point 

Tool: Spatial Analyst Tools > Hydrology > Snap Pour Point 

Purpose: Relocates user-supplied outlet points onto the cell of highest flow accumulation within a 

specified search radius. This step is essential before running the Watershed tool. 

Step 16.1: Create Outlet Points 

Create a point feature class named Outlets in the same projection as the DEM. Add a unique integer field 

named PourID. Use the Editor toolbar to digitise outlet locations: a basin gauge station, a culvert, the 

inlet of a reservoir, or any other location where a watershed boundary is required. Each point must have 

a unique PourID. 

Step 16.2: Configure Snap 

• Input raster or pour point feature data: Outlets 

• Pour point field: PourID 

• Input accumulation raster: FlowAcc 

• Snap distance: 100 m (3–4 cells for a 30 m DEM) 

• Output: SnappedOutlets (raster) 

Step 16.3: Verify Snap 

Display the snapped output as a point raster (or convert to feature class with Raster to Point) and overlay 

the original outlet points and the FlowAcc raster. Each snapped point should sit exactly on a high-

accumulation channel cell. If a snap distance of 100 m is insufficient, increase to 250–500 m, but check 

that the snapped point still corresponds to the intended channel and not to an adjacent tributary. 

17. Step 9: Watershed Delineation 

Tool: Spatial Analyst Tools > Hydrology > Watershed 

Purpose: Delineates the upslope contributing area for each snapped pour point. The output is a raster in 

which all cells draining to a single pour point share the PourID of that point. 

Step 17.1: Configure 

• Input flow direction raster: FlowDir_D8 

• Input raster or feature pour point data: SnappedOutlets 

• Pour point field: Value (for raster) or PourID (for features) 

• Output: Watershed_raster 

Step 17.2: Convert to Polygon 
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Convert the watershed raster to a polygon feature class using the Raster to Polygon tool (Data 

Management Tools > Raster > Raster to Other Format). Set Simplify Polygons = false to preserve the 

cell-wise boundary; check the option to dissolve adjacent polygons of the same value. The result is a 

polygon feature class with one polygon per watershed. 

Step 17.3: Compute Basin Area 

Add an Area_km2 field and calculate using Calculate Geometry (set the area unit to square kilometres). 

For very small watersheds (< 5 cells), suspect an unsnapped pour point and re-run Steps 8–9 with a 

larger snap distance. 

18. Step 10: Basin Tool (All Basins) 

Tool: Spatial Analyst Tools > Hydrology > Basin 

Purpose: The Basin tool delineates all natural drainage basins from the flow-direction raster without 

requiring user-supplied pour points. Each basin terminates at a flow-direction sink (typically the DEM 

edge or an internal drainage point). 

Step 18.1: Configure 

• Input flow direction raster: FlowDir_D8 

• Output: Basin_raster 

Step 18.2: Use Cases 

The Basin tool is appropriate when the analyst wishes to delineate all sub-basins within a study area 

without pre-defining outlets, for example in regional drainage characterisation or in initial reconnaissance 

of an unfamiliar terrain. The output is a raster in which each cell carries the integer ID of the basin to 

which it drains. Convert to polygons using Raster to Polygon for cartographic display and area 

computation. 

Note: The Basin tool typically produces many small basins along the DEM edge that have no hydrological 

meaning. Filter these by computing area and removing polygons smaller than a project-specific threshold 

(e.g., 1 km²). 

19. Cartographic Presentation of Hydrological Outputs 

Hydrological maps prepared for academic publication should follow the cartographic conventions 

specified in the Indian Society of Remote Sensing journal guidelines and the IAHS scientific publication 

standards. 

19.1 Symbology 

Layer Symbology Notes 

DEM Hillshade overlay with elevation 
colour ramp (terrain) 

Apply 50% transparency to elevation 
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Layer Symbology Notes 

Stream Network Polyline graduated by Strahler order Width: 0.3–1.5 mm; colour: blue (CMYK 
100,50,0,0) 

Watershed 
Boundary 

Polygon outline only Width: 1.0 mm; colour: black or dark red 

Pour Points / 
Outlets 

Triangle marker Size: 4–6 pt; colour: red 

Sub-basins (from 
Basin tool) 

Unique values, qualitative palette Use ColourBrewer Set3 or Pastel1 

19.2 Required Map Elements 

• Title: descriptive of basin name, year of DEM, and metric displayed 

• North arrow 

• Scale bar in metric units (km) 

• Legend with all classes labelled 

• Inset map showing the basin within the state and within India 

• Coordinate grid in DMS or decimal degrees on all four sides 

• Data source attribution (DEM source, year, resolution) 

• CRS / EPSG code in margin (e.g., “WGS 1984 UTM Zone 44N (EPSG:32644)”) 

• Author and date of map preparation 

• Export at 300 DPI in TIFF or PDF format for publication 
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PART III: APPLICATIONS, VALIDATION, AND 
REFERENCES 

20. Applications of Hydrological Analysis 

Application Domain Description 

Watershed Management 
Planning 

Delineation of watersheds and sub-watersheds for prioritisation 
under the Pradhan Mantri Krishi Sinchayee Yojana (PMKSY) and 
Integrated Watershed Management Programme (IWMP) 

Flood Hazard Assessment Extraction of channel networks and contributing areas as inputs to 
HEC-HMS, HEC-RAS, and MIKE 11 hydrodynamic models 

Soil Erosion Modelling Computation of slope length and steepness (LS) factor for the 
Revised Universal Soil Loss Equation (RUSLE) using flow-
accumulation-derived flow length 

Groundwater Recharge Studies Identification of zones of high topographic wetness index (TWI) for 
delineation of recharge potential in lateritic and alluvial aquifers 

Sediment Yield Estimation Sediment routing through stream networks using contributing area 
and slope-derived sediment delivery ratios 

Reservoir and Dam Site 
Selection 

Identification of suitable reservoir sites by combining basin area, 
slope, and storage capacity computations 

Drainage Density and 
Morphometric Analysis 

Quantification of basin morphometry (drainage density, bifurcation 
ratio, ruggedness number, hypsometric integral) for tectonic and 
geomorphic interpretation 

Environmental Flow Assessment Identification of channel network connectivity for ecological flow 
studies in regulated rivers 

Landslide Hazard Mapping Computation of contributing area as a predictor variable in 
physically-based slope stability models (e.g., SHALSTAB, 
SINMAP) 

Urban Drainage and Stormwater 
Planning 

Sub-catchment delineation for SWMM (Storm Water Management 
Model) inputs in urban hydrology 

21. Common Errors and Troubleshooting 

Error / Issue Possible Cause Solution 

Watershed contains only a 
few cells 

Pour point not snapped to a 
high-accumulation cell 

Run Snap Pour Point with a larger 
snap distance (250–500 m). Verify 
that the snapped point coincides with 
a channel. 

Stream network appears as 
parallel lines on flat terrain 

D8 algorithm artefact on planar 
surfaces 

Switch to D-Infinity or MFD; or apply 
minor noise to the DEM (± 0.01 m) 
using Raster Calculator before flow 
direction. 
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Error / Issue Possible Cause Solution 

Fill tool runs but produces 
unchanged DEM 

DEM has no sinks (rare) or Z 
limit is too low 

Verify by running the Sink tool first. 
Set Z limit to a high value or leave 
blank to fill all sinks. 

Watershed boundary cuts 
across a known basin 

Pour point placed off the 
channel; or DEM edge effect 

Re-snap the pour point. Buffer DEM 
extent by 10 percent and re-run the 
workflow. 

Stream network is too 
dense or too sparse 

Inappropriate flow-
accumulation threshold for 
terrain 

Test thresholds at half and double the 
initial value. Compare with Survey of 
India 1:50,000 sheets. 

Output projection differs 
from input 

Environment settings not 
applied 

Set Output Coordinate System and 
Snap Raster in Geoprocessing 
Environments before each tool run. 

No-data values in flow 
accumulation 

DEM contains no-data cells 
inside basin 

Fill no-data using Focal Statistics with 
mean filter, then re-run the workflow. 

Stream Order tool returns 
blank raster 

Input stream raster has values 
other than 1 

Re-run the Con expression to ensure 
stream cells equal 1 and all other cells 
are NoData. 

Slow performance on large 
DEM (> 10000 × 10000 
cells) 

Insufficient memory or 
unoptimised raster format 

Convert input to .tif with LZW 
compression; tile the DEM and 
process by sub-basin. 

Watershed polygon has 
irregular jagged boundary 

Raster cell-wise boundary 
preserved 

Apply a moderate smoothing using the 
Smooth Polygon tool with PAEK 
algorithm and tolerance of 1–2 cell 
sizes. 
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Appendix: Complete Tool and Morphometric Formula Reference 

A.1 Hydrology Toolset — Tool Reference 

Step Tool Name Inputs Output Toolbox Path 

1 Fill Raw DEM Filled DEM Spatial Analyst > 
Hydrology > Fill 

2 Flow Direction Filled DEM Flow direction raster 
(D8 codes) 

Spatial Analyst > 
Hydrology > Flow Direction 

3 Flow 
Accumulation 

Flow direction Accumulation raster 
(counts) 

Spatial Analyst > 
Hydrology > Flow 
Accumulation 

4 Con (Map 
Algebra) 

Accumulation 
raster 

Stream raster 
(1/NoData) 

Spatial Analyst > Map 
Algebra > Raster 
Calculator 

5 Stream Link Stream raster, Flow 
direction 

Link IDs Spatial Analyst > 
Hydrology > Stream Link 

6 Stream Order Stream raster, Flow 
direction 

Order raster 
(Strahler/Shreve) 

Spatial Analyst > 
Hydrology > Stream Order 

7 Stream to 
Feature 

Stream order, Flow 
direction 

Polyline feature class Spatial Analyst > 
Hydrology > Stream to 
Feature 

8 Snap Pour 
Point 

Outlets, 
Accumulation 

Snapped points (raster) Spatial Analyst > 
Hydrology > Snap Pour 
Point 

9 Watershed Flow direction, 
Snapped pour 
points 

Watershed raster Spatial Analyst > 
Hydrology > Watershed 

10 Basin Flow direction All-basins raster Spatial Analyst > 
Hydrology > Basin 

A.2 Flow Direction Encoding (D8) 

Direction Code Direction Code 

East 1 West 16 

Southeast 2 Northwest 32 

South 4 North 64 

Southwest 8 Northeast 128 

A.3 Morphometric Parameter Formulas 

Derived from outputs of the Hydrology toolset and used in standard morphometric analysis (Horton, 1945; 

Strahler, 1957; Schumm, 1956). 
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Parameter Symbol Formula Unit 

Stream Order U Hierarchical (Strahler/Shreve) Dimensionless 

Stream Number N_u Total count of segments of order u Count 

Stream Length L_u Total length of segments of order u km 

Mean Stream Length L_um L_u / N_u km 

Stream Length Ratio R_L L_u / L_(u−1) Dimensionless 

Bifurcation Ratio R_b N_u / N_(u+1) Dimensionless 

Drainage Density D_d Σ L_u / A km/km² 

Stream Frequency F_s Σ N_u / A 1/km² 

Drainage Texture R_t Σ N_u / P 1/km 

Form Factor R_f A / L_b² Dimensionless 

Circulatory Ratio R_c 4πA / P² Dimensionless 

Elongation Ratio R_e (2/L_b) × √(A/π) Dimensionless 

Compactness Coefficient C_c 0.2841 × P / √A Dimensionless 

Relief Ratio R_h H / L_b Dimensionless 

Ruggedness Number R_n H × D_d (with H in km) Dimensionless 

Where A = basin area (km²); P = basin perimeter (km); L_b = basin length (km); H = basin relief, the 

difference between maximum and minimum elevation (km); u = stream order. 

A.4 Recommended Flow-Accumulation Thresholds (30 m DEM) 

Climate / Terrain Cells Area (km²) 

Humid tropical (Western Ghats, North-East 
India) 

500–1000 0.45–0.90 

Sub-humid (Deccan, Eastern Ghats) 1000–2000 0.90–1.80 

Semi-arid (Rayalaseema, Marathwada, 
Saurashtra) 

5000–10000 4.50–9.00 

Arid (Thar, Kachchh) 10000–20000 9.00–18.00 

Urban / Engineered drainage 100–500 0.09–0.45 

A.5 Python (arcpy) Script Skeleton 

The following script automates Steps 1–7 of the workflow. Library versions: ArcGIS Pro 3.2 with Spatial 

Analyst extension; Python 3.9 (bundled arcpy). 

# Hydrology workflow automation — ArcGIS Pro 3.x import arcpy from arcpy.sa import *  
arcpy.CheckOutExtension('Spatial') arcpy.env.workspace = r'C:/Project/Workspace/hydrology.gdb' 
arcpy.env.overwriteOutput = True  dem = 'DEM_raw' threshold = 1000  # cells  # Step 1: Fill dem_fill 
= Fill(dem); dem_fill.save('DEM_fill')  # Step 2: Flow Direction (D8) flowdir = 
FlowDirection(dem_fill, 'NORMAL', '', 'D8'); flowdir.save('FlowDir_D8')  # Step 3: Flow Accumulation 
flowacc = FlowAccumulation(flowdir, '', 'FLOAT', 'D8'); flowacc.save('FlowAcc')  # Step 4: Stream 
Definition streams = Con(flowacc >= threshold, 1); streams.save('Stream_raw')  # Step 5: Stream Link 
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link = StreamLink(streams, flowdir); link.save('StreamLink')  # Step 6: Stream Order (Strahler) order 
= StreamOrder(streams, flowdir, 'STRAHLER'); order.save('StreamOrder_S')  # Step 7: Stream to Feature 
arcpy.sa.StreamToFeature(order, flowdir, 'StreamNetwork', 'SIMPLIFY')  
arcpy.CheckInExtension('Spatial') print('Hydrology workflow complete.') 

 

— End of Document — 
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