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Part 1: Theoretical Foundation 

1.1 What is Land Surface Temperature (LST)? 

Land Surface Temperature (LST) refers to the radiative skin temperature of the Earth’s surface 

as derived from satellite-based thermal infrared (TIR) sensors. It is a critical parameter in 

environmental science, urban climatology, agriculture, hydrology, and public health research. 

Unlike air temperature measured at meteorological stations, LST captures the spatial 

heterogeneity of surface thermal conditions at the pixel level, making it valuable for spatially 

explicit analyses such as Urban Heat Island (UHI) studies, drought monitoring, and 

evapotranspiration estimation. 

1.2 Why Landsat Data? 

The Landsat programme, operated jointly by NASA and the USGS, provides the longest 

continuous archive of moderate-resolution (30 m multispectral, 100 m thermal resampled to 

30 m) satellite imagery. Landsat 8 carries two key instruments: the Operational Land Imager 

(OLI) for visible/NIR/SWIR bands and the Thermal Infrared Sensor (TIRS) for thermal bands 

(Band 10 at 10.6–11.19 µm and Band 11 at 11.5–12.51 µm). The USGS recommends using 

Band 10 only for LST retrieval due to calibration uncertainties associated with Band 11 

(USGS, 2019). 

1.3 The General LST Retrieval Workflow 

The standard mono-window/single-channel approach involves the following sequential 

processes: 

Raw DN → TOA Spectral Radiance → Brightness Temperature → NDVI → Proportion of 

Vegetation → Emissivity → LST 
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Part 2: Data Acquisition 

2.1 Downloading Landsat Imagery 

Step 2.1.1: Navigate to USGS EarthExplorer (https://earthexplorer.usgs.gov/). 

Step 2.1.2: Create a free USGS account if one does not already exist. Click Register in the 

top-right corner, fill in the required credentials, and verify the email address. 

Step 2.1.3: Define the Area of Interest (AOI) under the Search Criteria tab using one of the 

following methods: Address/Place, Coordinates, Shapefile/KML Upload, or the Interactive 

Map interface. 

Step 2.1.4: Set the Date Range relevant to the study (e.g., summer months for UHI 

analysis). Set the Cloud Cover filter to less than 10% to ensure minimal atmospheric 

interference. 

Step 2.1.5: Select the Dataset: Navigate to the Data Sets tab. Expand Landsat → Landsat 

Collection 2 Level-1 → Check Landsat 8-9 OLI/TIRS C2 L1. 

Note: Use Level-1 (L1) data, not Level-2, because Level-2 products have already 

been atmospherically corrected and the standard LST workflow requires raw DN or 

TOA radiance as input. 

Step 2.1.6: Click Results to view available scenes. 

Step 2.1.7: Preview each scene by clicking the footprint or thumbnail icons. Select a scene 

with minimal cloud cover over the study area. 

Step 2.1.8: Click the Download button and select Product Options. Download the following 

individual bands: Band 4 (Red), Band 5 (NIR), Band 10 (TIR), and the MTL.txt metadata file. 

2.2 Understanding the Metadata (MTL) File 

Open the MTL.txt file in any text editor. Locate and record the following parameters: 

RADIANCE_MULT_BAND_10 = 3.3420E-04       → ML 

RADIANCE_ADD_BAND_10 = 0.10000            → AL 

K1_CONSTANT_BAND_10 = 774.8853            → K1 

K2_CONSTANT_BAND_10 = 1321.0789           → K2 

 

Parameter Symbol Typical Value (Band 
10) 

Purpose 

Radiance 
Multiplicative Factor 

ML 3.3420E-04 Converts DN to Radiance 

Radiance Additive 
Factor 

AL 0.10000 Converts DN to Radiance 
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Thermal Constant 1 K1 774.8853 Planck function constant 

Thermal Constant 2 K2 1321.0789 Planck function constant 

Table 1. Radiometric calibration parameters from the Landsat 8 MTL metadata file. 
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Part 3: Setting Up ArcGIS Pro 

3.1 Creating a New Project 

Step 3.1.1: Launch ArcGIS Pro. 

Step 3.1.2: Click New Project → Select Map template. 

Step 3.1.3: Name the project (e.g., LST_Analysis_StudyArea) and choose a folder location. 

Step 3.1.4: Click OK. A new map view will open. 

3.2 Setting the Coordinate System 

Step 3.2.1: In the Contents pane, right-click the Map → Properties. 

Step 3.2.2: Navigate to Coordinate Systems. 

Step 3.2.3: Set the coordinate system to match the Landsat data. Landsat imagery is 

typically delivered in WGS 1984 UTM Zone XX (where XX corresponds to the study area’s 

UTM zone). 

Step 3.2.4: Click OK. 

3.3 Adding Raster Data 

Step 3.3.1: Go to Map tab → Add Data → Add Data. 

Step 3.3.2: Navigate to the folder containing the downloaded Landsat bands. 

Step 3.3.3: Add the following: B4.TIF (Red Band), B5.TIF (NIR Band), B10.TIF (Thermal 

Band). 

Step 3.3.4: All three raster layers should now appear in the Contents pane and be 

displayed on the map canvas. 

3.4 Clipping to the Study Area (Optional but Recommended) 

Step 3.4.1: Go to Analysis tab → Tools → Search for Clip Raster (or Extract by Mask 

under Spatial Analyst). 

Step 3.4.2: Set Input Raster to Band 10 (repeat for Band 4 and Band 5), Feature Mask Data 

to the study area shapefile, and provide descriptive output names (e.g., B10_clipped.tif). 

Step 3.4.3: Click Run. Repeat for all three bands. 

Note: This step reduces processing time and focuses the analysis on the area of 

interest. 
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Part 4: Computing TOA Spectral Radiance 

4.1 Theory 

The Digital Numbers (DN) stored in the raw Landsat Band 10 raster must first be converted to 

Top-of-Atmosphere (TOA) spectral radiance using the radiometric calibration coefficients from 

the metadata file. The formula is: 

Lλ = ML × Qcal + AL 

Where Lλ is the TOA spectral radiance (W/(m²·sr·µm)), ML is the radiance multiplicative 

scaling factor for Band 10, Qcal is the quantised calibrated pixel value (DN) of Band 10, and 

AL is the radiance additive scaling factor for Band 10. 

4.2 Implementation in ArcGIS Pro 

Step 4.2.1: Navigate to Analysis tab → Tools → Search for Raster Calculator. 

Note: The Spatial Analyst Extension must be enabled. Go to Project → Licensing → 

Ensure Spatial Analyst is checked. 

Step 4.2.2: In the Raster Calculator expression box, type: 

0.0003342 * "B10_clipped.tif" + 0.1 

Step 4.2.3: Set the Output raster to a meaningful name, e.g., TOA_Radiance.tif. 

Step 4.2.4: Click Run. 

Step 4.2.5: Verify the output using the Identify tool. Typical values range from 

approximately 4 to 15 W/(m²·sr·µm). 
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Part 5: Conversion to Brightness Temperature (BT) 

5.1 Theory 

Brightness temperature is derived by inverting the Planck radiance function. It represents the 

temperature a blackbody would need to have in order to emit the same amount of radiance at 

the given wavelength. The formula is: 

BT = K2 / ln(K1 / Lλ + 1) − 273.15 

Where BT is the brightness temperature in degrees Celsius, K1 = 774.8853, K2 = 1321.0789 

(for Landsat 8 Band 10), Lλ is the TOA spectral radiance, and subtracting 273.15 converts 

from Kelvin to Celsius. 

5.2 Implementation in ArcGIS Pro 

Step 5.2.1: Open Raster Calculator again. 

Step 5.2.2: Enter the following expression: 

(1321.0789 / Ln((774.8853 / "TOA_Radiance.tif") + 1)) - 273.15 

Step 5.2.3: Set the Output raster to Brightness_Temp.tif. 

Step 5.2.4: Click Run. 

Step 5.2.5: Verify the output. Brightness temperature values typically range from 15°C to 

50°C depending on the climate zone, season, and land cover. 
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Part 6: Computing NDVI 

6.1 Theory 

The Normalised Difference Vegetation Index (NDVI) quantifies the density and health of 

vegetation. It is computed from the red and near-infrared reflectance values and ranges from 

−1 to +1, where higher values indicate denser vegetation. In the context of LST retrieval, NDVI 

is used as an intermediate variable to estimate the proportion of vegetation and subsequently 

the land surface emissivity. 

NDVI = (NIR − Red) / (NIR + Red) = (Band 5 − Band 4) / (Band 5 + Band 4) 

6.2 Implementation in ArcGIS Pro 

Step 6.2.1: Open Raster Calculator. 

Step 6.2.2: Enter the following expression: 

Float("B5_clipped.tif" - "B4_clipped.tif") / Float("B5_clipped.tif" + 

"B4_clipped.tif") 

Note: The Float() function ensures floating-point division rather than integer division, 

which would truncate decimal values. 

Step 6.2.3: Set the Output raster to NDVI.tif. 

Step 6.2.4: Click Run. 

Step 6.2.5: Verify the output: Water bodies (NDVI < 0, typically around −0.1 to −0.3), Bare 

soil/Built-up (NDVI ≈ 0.0 to 0.2), Sparse vegetation (NDVI ≈ 0.2 to 0.4), Dense vegetation 

(NDVI ≈ 0.4 to 0.8+). 
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Part 7: Proportion of Vegetation (Pv) 

7.1 Theory 

The proportion of vegetation (Pv) quantifies the fractional vegetation cover within each pixel. 

It is derived from NDVI using the following equation: 

Pv = ((NDVI − NDVImin) / (NDVImax − NDVImin))² 

Where NDVImin = 0.2 (representing bare soil) and NDVImax = 0.5 (representing full 

vegetation). These threshold values can be adjusted based on the histogram of the NDVI 

raster. 

7.2 Implementation in ArcGIS Pro 

Step 7.2.1: Open Raster Calculator. 

Step 7.2.2: Enter the following expression: 

Square(("NDVI.tif" - 0.2) / (0.5 - 0.2)) 

Step 7.2.3: Set the Output raster to Pv.tif. 

Step 7.2.4: Click Run. 

Step 7.2.5: Output values should range from 0 (bare soil) to 1 (full vegetation). Values 

slightly below 0 or above 1 may occur at the extremes; these can be reclassified if 

necessary. 
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Part 8: Land Surface Emissivity (ε) 

8.1 Theory 

Emissivity (ε) describes the efficiency of a surface in emitting thermal radiation relative to a 

blackbody. It is a dimensionless quantity ranging from 0 to 1 and varies by surface type: water 

(~0.99), vegetation (~0.98), bare soil (~0.97), built-up surfaces (~0.95), and metals (~0.88–

0.93). 

The NDVI-based emissivity estimation method (Sobrino et al., 2004) uses the following 

equation: 

ε = 0.004 × Pv + 0.986 

This equation assumes emissivity of vegetation (εv) ≈ 0.990, emissivity of soil (εs) ≈ 0.986, 

and a geometric distribution factor (F) ≈ 0.55. 

8.2 Implementation in ArcGIS Pro 

Step 8.2.1: Open Raster Calculator. 

Step 8.2.2: Enter the following expression: 

0.004 * "Pv.tif" + 0.986 

Step 8.2.3: Set the Output raster to Emissivity.tif. 

Step 8.2.4: Click Run. 

Step 8.2.5: Verify the output. Emissivity values should range approximately from 0.986 (bare 

soil) to 0.990 (dense vegetation). 
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Part 9: Land Surface Temperature (LST) 

9.1 Theory 

The final LST is derived by correcting the brightness temperature for surface emissivity effects. 

The equation is: 

LST = BT / (1 + (λ × BT / ρ) × ln(ε)) 

Where BT is the brightness temperature (°C), λ = 10.8 µm (wavelength of emitted radiance), 

ρ = h × c / σ = 1.4388 × 10⁻² m·K (h = Planck’s constant, c = speed of light, σ = Boltzmann 

constant), and ε = land surface emissivity. The simplified constant used in the formula is λ/ρ = 

0.00115/1.4388. 

9.2 Implementation in ArcGIS Pro 

Step 9.2.1: Open Raster Calculator. 

Step 9.2.2: Enter the following expression: 

"Brightness_Temp.tif" / (1 + (0.00115 * "Brightness_Temp.tif" / 

1.4388) * Ln("Emissivity.tif")) 

Step 9.2.3: Set the Output raster to LST.tif. 

Step 9.2.4: Click Run. 

Step 9.2.5: Verify the output. LST values should be physically realistic: cool surfaces (water, 

dense forests) at 18–25°C, moderate surfaces (agricultural land) at 25–35°C, and hot 

surfaces (bare soil, asphalt, built-up areas) at 35–50°C+. 

Note: If values appear unreasonably high or low, double-check the MTL constants 

and ensure all intermediate rasters are correct. 
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Part 10: Symbology and Classification 

10.1 Applying a Colour Scheme 

Step 10.1.1: In the Contents pane, right-click the LST.tif layer → Symbology. 

Step 10.1.2: The Symbology pane will open on the right side. 

Step 10.1.3: Under Primary Symbology, select Classify (for discrete classes) or 

Stretched (for a continuous gradient). 

Option A: Stretched Symbology (Continuous) 

Set Colour Scheme to a diverging ramp such as Blue-Yellow-Red or Cyan-to-Red. Under 

Stretch Type, select Minimum-Maximum or Standard Deviation. This provides a smooth, 

continuous gradient from cool to hot zones. 

Option B: Classified Symbology (Discrete) 

Set the Method to Manual or Natural Breaks (Jenks). Set the Number of Classes (e.g., 5 or 

7). Define the class breaks manually: 

Class Temperature Range Colour Interpretation LULC Association 

1 < 20°C Dark Blue Very Cool Water bodies, Dense 
forests 

2 20–25°C Light Blue Cool Wetlands, Irrigated fields 

3 25–30°C Yellow Moderate Agricultural land 

4 30–35°C Orange Warm Sparse vegetation, 
Fallow 

5 35–40°C Red Hot Built-up, Bare soil 

6 > 40°C Dark Red Very Hot Industrial, Impervious 

Table 2. Suggested LST classification scheme with land use/land cover associations. 

10.2 Adding Contour Lines (Optional) 

Step 10.2.1: Go to Analysis → Tools → Search for Contour. 

Step 10.2.2: Set Input Raster to LST.tif, Contour Interval to 2 (degrees Celsius), and Output 

Feature Class to LST_Contours. 

Step 10.2.3: Click Run. 
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Part 11: Map Layout and Cartographic Design 

11.1 Creating a Layout 

Step 11.1.1: Go to Insert tab → New Layout. 

Step 11.1.2: Select an appropriate page size: A4 (210 × 297 mm) for standard academic 

submissions, A3 for poster presentations, or Letter (8.5 × 11 inches) for US-standard 

publications. 

11.2 Inserting the Map Frame 

Step 11.2.1: In Layout view, go to Insert tab → Map Frame → Select the map. 

Step 11.2.2: Draw a rectangle on the layout where the map should appear. 

Step 11.2.3: Adjust the extent by right-clicking the map frame → Activate → Pan/zoom to 

the desired view → Click outside the frame to deactivate. 

11.3 Adding Cartographic Elements 

Title 

Insert → Text → Rectangle → Type the map title. Use Times New Roman, Bold, 16 pt for 

academic publications. 

Legend 

Insert → Legend → Click on the map frame. Double-click the legend to edit: remove 

unnecessary layers, rename items (e.g., LST (°C)), and adjust font size and spacing. 

Scale Bar 

Insert → Scale Bar → Select Alternating Scale Bar style. Place it at the bottom of the map. 

Set Division units to Kilometres with 4–5 divisions. 

North Arrow 

Insert → North Arrow → Select a style and place it in the upper-right corner. 

Grid/Graticule 

Right-click the Map Frame → Properties → Grids → Add Grid. Choose Measured Grid (for 

projected coordinates) or Graticule (for geographic coordinates). Configure interval, label 

format, and line style. 

Data Source and Credits 

Data Source: Landsat 8 OLI/TIRS, USGS EarthExplorer. Acquired: [Date]. Projection: WGS 

1984 UTM Zone XX. Processed in ArcGIS Pro [Version]. 
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11.4 Exporting the Final Map 

Step 11.4.1: Go to Share tab → Export Layout. 

Step 11.4.2: Choose the format: PDF (best for publications), TIFF (best for high-resolution 

raster images), or JPEG/PNG (best for web or presentations). 

Step 11.4.3: Set resolution to 300 DPI minimum for journal publications, 150 DPI for 

presentations and reports. 

Step 11.4.4: Click Export. 
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Part 12: Validation and Accuracy Assessment 

12.1 Validation Methods 

Ground Truth Comparison 

Compare derived LST values with in-situ temperature measurements from weather stations 

within the study area. Extract pixel values at station locations using the Extract Values to 

Points tool in ArcGIS Pro. 

Cross-Validation with MODIS LST Products 

Compare Landsat-derived LST with MODIS LST products (MOD11A1/MYD11A1) at 

corresponding dates. While MODIS has coarser spatial resolution (1 km), it serves as a useful 

benchmark. 

Statistical Metrics 

Calculate RMSE (Root Mean Square Error), MAE (Mean Absolute Error), and correlation 

coefficient (R²) between derived LST and reference data. 

12.2 Extract Values to Points 

Step 12.2.1: Prepare a point shapefile of weather station locations with recorded 

temperatures. 

Step 12.2.2: Go to Analysis → Tools → Search for Extract Values to Points. 

Step 12.2.3: Set Input Point Features to the weather stations shapefile, Input Raster to 

LST.tif, and Output Point Features to LST_Validation_Points. 

Step 12.2.4: Click Run. 

Step 12.2.5: Open the attribute table. A new field RASTERVALU will contain the extracted 

LST values. Compare these with the recorded ground truth temperatures. 
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Part 13: Common Errors and Troubleshooting 

Problem Cause Solution 

LST values are 
unrealistically high 
(>70°C) 

Incorrect ML/AL or K1/K2 
values 

Re-check the MTL file and ensure 
correct values 

LST values are all 
negative 

BT was not converted from 
Kelvin to Celsius 

Ensure −273.15 is included in the BT 
formula 

NDVI values are all 0 Integer division instead of 
float 

Use Float() function in the NDVI formula 

Raster Calculator gives 
an error 

Spaces in file path or name Move data to a path with no spaces 

Black pixels in output NoData values from clipping Use Set Null or check the extent of the 
clip boundary 

Emissivity values > 1 or 
< 0.9 

Incorrect Pv values Re-check NDVImin and NDVImax 
thresholds 

Table 3. Common errors encountered during LST retrieval and their solutions. 
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Part 14: Complete Formula Reference Sheet 

Step Formula Output 

TOA Radiance Lλ = ML × Band10 + AL W/(m²·sr·µm) 

Brightness Temp BT = (K2 / Ln(K1/Lλ + 1)) − 273.15 °C 

NDVI (Band5 − Band4) / (Band5 + Band4) −1 to +1 

Proportion of 
Vegetation 

Pv = ((NDVI − NDVImin)/(NDVImax − 

NDVImin))² 
0 to 1 

Emissivity ε = 0.004 × Pv + 0.986 0.986 to 0.990 

LST BT / (1 + (0.00115 × BT / 1.4388) 

× Ln(ε)) 
°C 

Table 4. Complete formula reference for LST retrieval from Landsat 8 Band 10. 
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